Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My stepper doesn't move
#1
Hi there.

I have some problems with my stepper motor. Here are datasheet and characteristics:
http://www.robot-italy.com/it/stepper-motor-nema-17-48mm-42byghm809.html

You can see what happen in youtube video:





I've set full step via dip switch and video mode from miniEngine interface. But the same if I use BED standard 1/16 step and so on.

If I increase the current via Big Easy Driver the system shutdown and I have to power off the battery (a 12V 7A battery), Then I decrease the current on Big Easy Driver and I'm able to restart the system.

In timelapse mode it does the same. It doesn't move and if I increase the current on BED I have to restart the system.

It does the same both attached in motor1 or motor2. Both in angular header or RJ14 plug.

Any hint? Maybe the motor can be damaged?

Any help would be really appreciated.

Thanks a lot.
Reply
#2
Don't know why but askimet has automatically banned my previous account after writing the message above. I'm not a bot nor a spammer.
Reply
#3
Photo 
Hi, there are a lot of faulty Big Easy drivers on the market being sold cheap! They have two components, a resistor and a capacitor, swapped and mounted in the wrong place and this causes the motors to pulse and not step properly, I know as I bought a bunch of them and some others on this forum have also  been caught. Maybe you have one of these? There is a post about this in this forum and pictures showing the good and bad version but I can't find the post just now.

Here also is the link for the  driver and manual, circuits etc.     http://www.schmalzhaus.com/BigEasyDriver/  
Have a close look at the picture of the board and the components where the VCC and GND print is.
   




Hope this is helpful.
Peter
Reply
#4
Peter thank you very much for pointing about this issue. Without your help I never never think about a BED problem because I've bought two as original and not a copy or fake:
http://www.ebay.it/itm/181864646184?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

And yes they are fake for sure. Very disappointed by. I've never bought fake component in my life and make me angry.

Below a photo of mine:
[Image: IMG_0576.jpg]upload immagini gratis

Very very disappointed. So I have to swap the two component over VCC and GND... But I don't know how to work with SMD component. Nor I have a magnifying glass or something similar to work with... and I also have some difficult in desoldering BED and substitute it with another one (this time original from Italy) Sad

They make me a big damage.

This is the original post here on the forum:
http://forum.airiclenz.com/showthread.php?tid=6871&highlight=big+easy+driver
Reply
#5
Sorry to hear of the bad news but you are not alone. It seems a shame that such a good driver has been marred by so many faulty copies. I need to buy more but hesitate to know who to trust.  
I also noticed that you have not joined the link on the driver to select the 3.3volt option which you need to do.
I have tried to unsolder and swap those components but failed miserably so have resigned to dump them.
Do  you have the circuit diagram for the driver from my link above? It is C7 and R12 that need to be swapped.
All the best.
Peter
Reply
#6
hey!
Yep your Bigeasy driver is faulty, on step signal you have capacitor instead of resistor. If you have tools and skill you have re-soldered them and it will probably be ok.

simon
Reply
#7
Hi.

Feel very angry about the ebay fraud. I have tried to desolder the big easy driver to have it changed with a good one I own but maybe I have made a big more damage. See the image with my screwdriver I have made a scratch on BED pcb Sad Sad Sad

[Image: IMG_0578.jpg]caricare immagini

And what about join the link to select 3.3v? What I have to do? I have an original one for sure bought some times ago.
Reply
#8
solder the 2 pads (3/5V) to connect them
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)