Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LCD kind of inverted???
#1
For my first post I don't want to start with the Problems but want to thank you for the great Development - kind of straight Forward!

So... I'm stuck with the Drivers (...or an faulty Display???)

I of course use the latest UTFT Library
The driver S6D1121 (ITDB24E_16) just comes up with the Backlight (White Screen)...

ILI9325D (TFT01_24_16) shows something like an inverted Image wich is at the beginning kind of readable with the bigger letters but fades out to unreadable within minutes.

Has there been an Hardware change by Itead or is mine just a faulty one...
Are you aware of any changes???

Best Regards, Daniel
Reply
#2
The exact same Problem is shown here at 00:28 onward





I also contacted Rinky-Dink (UTFT) but I'm still waiting for an reply
Reply
#3
Got an email from ITEAD...
I can't test it in the next days but I guess this isn't it...

Dear Daniel,


There is a problem with this miniEngine, the RD pin is connected to 5V. It should be connected to 3.3V.

The driver is ILI9325D right now.

Could you try the demo code from UTFT library?

And remember to modify this line.

UTFT myGLCD(TFT01_24_16,39,38,2,3);

Remember to switch the bit to 16bit on the module.
Reply
#4
(12-14-2015, 11:22 PM)daniel_reichts Wrote: Got an email from ITEAD...
I can't test it in the next days but I guess this isn't it...

Dear Daniel,


There is a problem with this miniEngine, the RD pin is connected to 5V. It should be connected to 3.3V.

The driver is ILI9325D right now.

Could you try the demo code from UTFT library?

And remember to modify this line.

UTFT myGLCD(TFT01_24_16,39,38,2,3);

Remember to switch the bit to 16bit on the module.
Hi Daniel,

I had the same problem as seen in the video. They also tould me about the RD pin being 5V but that's not the case. It's 3.3volts as it should be so that's not the problem. 
To put it simple, the lcd is faulty. I got a new one from itead after 2 defective unit's. The last one i received works perfect. No change to the miniengine code or anything.  

Good luck, hope this helps
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)