Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
compile error
#1
hello I am getting following while trying to compile for the first time can anyone tell me what could be the problem ;

Arduino: 1.6.6 (Windows 10), Board: "Arduino Duemilanove or Diecimila, ATmega328"

Build options changed, rebuilding all
In file included from C:\Users\mankomal\Desktop\Gmail Downloads\miniEngine2-master\miniEngine2-master\Software\miniEngine2\miniEngine2.ino:40:0:

C:\Users\mankomal\Documents\Arduino\libraries\DueTimer/DueTimer.h:108:3: error: #error Oops! Trying to include DueTimer on another device?

#error Oops! Trying to include DueTimer on another device?

^

exit status 1
Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.
Reply
#2
Hi,

seems like you have choosen the wrong arduino in the software.

In the Arduino software you have to look for the right name og the board. I had the same probleme because there the aduino one (ore something like that) was marked and not the arduino duo.

Regards,

Chris
Reply
#3
Hey!
I had the same problem.
Check under... tools -> arduino due (programing port),.. then in popup choose the Boards manager

in the new window which opens check if you have installed the arduino SAM boards,... I have to install the package and than it starts to work with no errors.

Have a nice day
simon
Reply
#4
(11-14-2015, 05:50 PM)symon Wrote: Hey!
I had the same problem.
Check under... tools -> arduino due (programing port),.. then in popup choose the Boards manager

in the new window which opens check if you have installed the arduino SAM boards,... I have to install the package and than it starts to work with no errors.

Have a nice day
simon

Hello 

Thanks this is resolved but now I am getting new error : 
Arduino: 1.6.6 (Windows 10), Board: "Arduino Due (Programming Port)"


exec: "/bin/arm-none-eabi-g++": file does not exist
Error compiling.

  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.

I am using windows 10
Reply
#5
any idea someone, how can i resolve this
Reply
#6
You could try using an older Arduino SDK.
Reply
#7
thanks Airic it worked on 1.5.5-r2
Reply
#8
I'm new and I'm interested in this topic. Thank you!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)