Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Big Easy Driver pot problem
#1
We have just come back from a trip into very remote, central Australia's desert, to do some time lapse of the Milky Way and desert scenery. We had two sliders and two MiniEngine2 controllers with us. The tracks were very rough and took its toll on the camper trailer, four wheel drive car and some of our equipment. One of the controllers didn't want to drive the stepper smoothly which was frustrating as everything was tested at home and all worked well there. Once out in the middle of no where it was too late to be able to fix it so it was down to the other controller and slider. We got some good slider shots but then the LiPo charger died and we were then unable to use the slider and controller from LiPo batteries. Un deterred we then used a camera on a tripod and did time lapse with one of those cheap hand held remote controls.
Anyhow to the point. Now back home, I found the potentiometer on the stepper driver  to be really sensitive to touch. It looks like the wiper contact is not making firm contact on the track. I have cleaned it with electrical cleaner but no improvement to the motor movement. I can adjust the pot so the motor runs smoothly but after a short time it goes rough again. If I simply push on the pot the motor runs smoothly again indicating to me a contact problem. I will either have to replace the board, which will be hard as I hard wired it in, or the pot and use a larger more robust pot. I recall another post somewhere on this forum of problems trying to  get the motor to run smoothly and I guess this is the same problem. If I can replace the pot I would use a multi turn type that has definite stops either end.
Once I get the time to try this I will report back.
Cheers
Peter
Reply
#2
Hello Peter,


first of all, thank you for your feedback! I hope you were able to get som great footage even though you had problems with a Big Easydriver (BED). Here come some questions:

  • Was it just one of the two on the miniEngine or both? 
  • Did you maybe just use solder in one BED?
  • If there were two, did you have the problem on both of the motor ports?
  • Did you use an enclosure around the miniEngine?
Generally I can agree on the fact that the potentiometer need some careful tuning but once it is set up, I never had problems with them again. Even touching them did not bring the setup out of tune. I guess you got a bad BED Sad

I designed an enclosure which allows for tweaking the potentiometers even while the miniEngine is enclosed (should be contained in the GitHub download). Maybe this helps for the next trip:

[Image: miniE_case_3D.jpg]

Cheers,
Airic
Reply
#3
Hi Airic, I hope you don't think I am criticizing your controller as that is not the case, they are excellent and I expect to be ordering another soon. The trip was very demanding on all our equipment and yes we got some good time lapse which I might post on here eventually. Yes I had the controllers in an enclosure although you might laugh at them as I used clear plastic clip lid lunch boxes with holes in the lid for the buttons and selection knob... cheap and cheerful! One slider used a toothed belt and the other a threaded rod so the settings were very different, however swapping over the SD card in the controller would have changed the setting to suit its controller.
The driver boards had been soldered onto the shield and one had the touchy pot. I can't say if the pot was touchy due to the rough trip or was just a week component waiting to fail. The other driver works ok as does the other controller. What also clouded the problem was the wiring in the cable to the motor had broken so adjusting the pot in the field never got the motor running smoothly anyhow. All up, a very interesting trip and I will be better prepared for the next one.
Cheers
Peter
Reply
#4
UPDATE
So I removed the little trim pot and wired in a bigger multi turn 10 k pot and now that driver is easy to adjust and is stable. Since I had never extensively tested the driver for motor 2 on that controller I thought I should set it up ready for future use. Well I could not get it to remain stable Huh Further checking found it had 4.95 volts on the VCC instead if 3.3volts. Would that be the problem? The jumper was tested and R7 was definitely grounded so the reg should have supplied 3.3 volts. R8 and R6 had the correct values printed on them but they metered out slightly different values compared to the driver board that worked and gave 3.3V. Running the measured values through the formula still gave about3.3 volts so I don't understand why the reg is supplying 4.95V. At this stage I will replace that driver unless someone has a better idea. Maybe put a trim pot in the reg adjust line?
cheers
Peter
Reply
#5
...it sounds more and more that you received a bad one. Due to the fact that you had problems with it and that it continues to behave strangely, replacing it is probably the best you can do.
Reply
#6
Excellent post. Thank you very much!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)