Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Saving Settings
#1
I can't seem to save any settings I set. Is this normal?
Reply
#2
(03-06-2015, 07:12 AM)jeenglebeanz Wrote: I can't seem to save any settings I set. Is this normal?

No this is not normal. Which version are you using? Is there a SD card int the card slot? 

Please do the following: format a SD card with FAT32 and then input it into the miniEngine. Start the miniEngine and wait until it booted. Then shut it down again. Check the SD card on your computer. There should be 2 files on it now.

/Airic
Reply
#3
I figured out the problem. I failed to read in the notes the part about putting an SD into the screen to save settings. I am sorry you have to put up with my incompetence, but I appreciate that you do so good sir!

Thank you, Airic
Reply
#4
Hi there

I just formatted (FAT 32) 3 cards, 4GB up to 32GB.
None of them seems to have two files on it when being put back in the card reader, nor does the Miniengine save any configuration.
I put in the card after I uploaded the sketch.

Any advice welcome, thanks!

Happy Easter
xlwksc
Reply
#5
Still trying to save MiniEngine 2 program data on my various SD cards, but no success so far. Contacts of the card holder on the ITEAD display shield seem to be fine (visually).
Last thing I want to to do is to replace the ITEAD shield  Rolleyes

Any ideas welcome, thanks!

Juerg
Reply
#6
(04-08-2015, 09:26 AM)xlwksc Wrote: Still trying to save MiniEngine 2 program data on my various SD cards, but no success so far. Contacts of the card holder on the ITEAD display shield seem to be fine (visually).
Last thing I want to to do is to replace the ITEAD shield  Rolleyes

Any ideas welcome, thanks!

Juerg

The only idea that I have is to push the miniEngine shield down onto the Arduino as much as possible. The connector in the middle (labeled "SPI") needs to make contact with the 2x3 pin header on the Arduino. If this header is not soldered to the bottom side of the shield, it will not work!

/Airic
Reply
#7
Hi Eric

I wish I could say it was just about soldering...  Rolleyes

Do you allow people to further participate in this great forum who forgot to install the 2x3 pin header completely?
Idea

Thanks mate!
Juerg
Reply
#8
I am also unable to save settings to the sd card. I checked the SPI connections and all the pins have continuity from one board to the other. None of the pins are shorted. I also checked all the pins to the TFT, all fine and nothing shorted. I've tried all the steps above. I'm updated to the latest 2.0.7 pre version. Does the brand of sd card matter or the size? I'm using a PNY 4gb card, smallest one I have.

thanks,
~Ben
Reply
#9
Did you format the card to FAT?

Reply
#10
yes, multiple times. still nothing.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)