Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Forum in deutscher Sprache
#21
(10-26-2014, 02:22 PM)Kamel Wrote: Das Oszilloskop hat die möglichen Fehlerquellen eingeschränkt.
An den "step"-Pins auf dem Display-Shield ist selbst bei Motorbetrieb nur ein Rauschen im Millivoltbereich zu sehen.
"Enable" zeigt, wie es sein soll, nur High.
"Direction" bekommt beim Starten des Motors kurz ein High und geht dann direkt auch Low und bleibt dort.
Die Spannungsversorgung zum Motorshield hin funktioniert auch richtig.

Hallo,

da scheinbar beide Arduinos nicht richtig funktionieren, kann es eigentlich nur an einem der beiden shields liegen. Du kannst allerdings den Arduino testen um zu checken ob alle Pins funktionieren, so wie sie sollen. Die sind die Pins, die mit der Motorsteuerung zu tun haben:

Code:
#define PIN_MOTOR1_STEP              11
#define PIN_MOTOR1_DIR               12
#define PIN_MOTOR1_ENABLE            13

#define PIN_MOTOR2_STEP              8
#define PIN_MOTOR2_DIR               9
#define PIN_MOTOR2_ENABLE            10

ansonsten empfehle ich die Shields mit einem Multimieter noch mal auf Durchgang oder Kurzschlüsse zu überprüfen. Ein weitere Tip is, den Kontakt der Motoranschlüsse zu checken. Ich hatte es schon, dass ein Stecker nicht richtig gekrimpt war und die Motoren sich in etwa wie bei dir verhalten haben.

Viel Erfolg!
Reply
#22
Moin,

ich bin gerade dabei meinen Slider zu planen.

MiniEngine V2 ist sehr schnell eingetroffen, danke für den Fixen Versand. Das Arduino Due habe ich auch schon da, ebenso einen Stepper Motor, Riemen und Zahnräder. Das Big Easy Driver Board und der Monitor sind noch auf dem Weg. Den Monitor mußte ich direkt beim Hersteller ordern, da kein Händler in Deutschland es auf Lager hatte. Die Slider Schiene habe ich letzte Woche bei Igus bestellt, leider noch nicht versendet.

Nun gehe ich gerade die Liste durch und wollte mir die noch benötigten Buchsen, Stecker und Kabel bestellen.

Wobei ich mir momentan nicht sicher bin, ist das Kamera Auslösekabel. Reicht da ein Fernauslöserverlängerungskabel oder muß es ein spezielles Kabel sein?

Benutzen möchte ich eine Sony RX100M3 und eine EOS 70D (+Camcorder der braucht ja kein Kabel Wink)

Diese habe ich rausgesucht:
http://www.ebay.de/itm/291328827284
http://www.ebay.de/itm/261587490621

Am FreeCad habe ich mir schon mal ein paar Halter für Umlenkung, Motorhalter und Standfüße gezeichnet. Die werde ich mir wahrscheinlich Lasern lassen, mal schauen. Mir fehlt vernünftiges Schneidewerkzeug... Bei Fabtools gibt es die Teile fertig geschnitten pro Teil von 5-9€.

Hoffe das funktioniert so alles wie ich mir das Vorstelle und aufgemalt habe Wink

Falls ja, werde ich die CAD Zeichungen gerne zur Verfügung stellen, für Lasern / Wasserschneiden oder 3D Druck. Beim 3D Druck weiß ich mangels Erfahrung aber nicht wie Dick das sein muss damit es auch hält.

Danke + Gruß Christian


Attached Files Thumbnail(s)
                   
Reply
#23
(08-18-2015, 08:54 PM)christian76 Wrote: Diese habe ich rausgesucht:
http://www.ebay.de/itm/291328827284
http://www.ebay.de/itm/261587490621

Sollten beide funktionieren. Falls nicht kannst du auch mal bei Triggertrap schauen.
Viel Spaß beim Basteln!
Reply
#24
Danke. Werde mir die Kabel bestellen.

Zwischenstand:

Gestern kam das Display aus Hong Kong. Es fehlen noch die beiden Big Easy Driver Platinen, werde gleich beide drauf löten, auch wenn ich aktuell nur einen Motor ansteuern möchte.

Beim Programmieren hatte ich immer einen Fehler, beim übertragen der Daten (lag an mir):

Quote:C:\Users\Christian\Documents\Arduino\libraries\DueTimer/DueTimer.h:95:3: error: #error Oops! Trying to include DueTimer on another device?
 #error Oops! Trying to include DueTimer on another device?
  ^
miniEngine2.ino:46:20: fatal error: malloc.h: No such file or directory
compilation terminated.
Fehler beim Übersetzen

Die Arduino Software wählt die Uno als Platine aus. Ich habe in der Liste die Due einfach übersehen Wink Da diese am Ende steht. War wohl zu spät gestern Abend...

Beide Platinen habe ich gleich mit allen möglichen Steckern / Buchsen versehen und auch die DIP - Schalter zur Schrittmotoren Einstellungen drauf gelötet.

Jetzt fehlt noch Kleinkram für die Schiene und die beiden BED Platinen.


Attached Files Thumbnail(s)
   
Reply
#25
Weiter gehts. miniE V2 ist ins Gehäuse eingezogen:

   

Und die Schiene nähert sich der Fertigstellung:

   

   

   
Reply
#26
Sieht klasse aus! Wann gibt es den ersten Democlip Wink
Reply
#27
Wink 
Sieht echt super aus. Auch mein gefertigtes Gehäuse  Big Grin Big Grin
Mit der Schiene hab ich auch mal versucht nen Slider zu bauen, allerdings hatte ich nicht so eine tolle Konstruktion für den Motor und die Umlenkung.
Acrylic enclosures for the Mini Engine V1 and V2. 
Please visit shop.epsh.de

And for more information please visit www.epsh.de
Reply
#28
Welchen Akku benutzt ihr und wie lange hält das so?
Reply
#29
(09-17-2015, 10:01 PM)Bastian Wrote: Welchen Akku benutzt ihr und wie lange hält das so?

Jeder 12V Akku sollte funktionieren. Ein Beispiel wäre eine Motorradbatterie. Ich benutze eine LiPo Akku wegen der besseren Energiedichte (allerdings ist mit diesem Typ Batterie eine gehörige Portion Vorsicht geboten, da die Akkus weder unter- noch überladen werden dürfen).

Die Laufzeit kannst du ausrechnen indem du die mAh der Batterie mit dem Verbrauch des Systems verrechnest. Hier ein Beispiel:

10.000 mAh Batterie
die miniEngine v1 saugt maximal 800mA

10.000 mAh / 800 mA = 12,5h
Reply
#30
Danke für die Antwort. Ich besitze ein Motorrad und mir ist die Batterie doch ein wenig unkomfortabel :-)
Aber es gibt ja einige Powerbank die auch 12V als Ausgang haben, das sollte auch reichen.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)