Thread Rating:
  • 2 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
miniEngine 2 problems
(06-25-2015, 12:08 PM)wsp35 Wrote: ...Unrelated question, with SMS timelapse, is there anyway to continue shooting timelapse before or after the move?

If you use the miniEngine Studio you can define a move that has no movement in the first or last part of the setup. There is no way to let it run after the program finished though.
(04-24-2015, 10:07 AM)Wire14 Wrote: Hi,

I had the same Problem. I solved it by using two separate cables, one for the motor and one for the limit switch. A Problem could be the lenght of the cable. Airics tip was to use a cable where every wire is shielded.

Regards Chris

Hi All,

I'm also trying to use one cable (cat5 RJ45) for the stepper motor and the limit switches. So that will take a minimum of 7 wires. In the patchcable there are 8. They are twisted by pair, to get rid of some distortion signals. But thats not enough.

Now I found out that indeed powering the stepper motor triggers one of the limit-switch inputs immediately because of inductance I think when only using 1 cable.

Here's what I did :
I put a 100K resistor in series with each of the input-wires from the limit-switches CLOSE to "LSM1 motor 1" and "LSM1 motor 2" connection on the PCB. The ground is direct connected.

Guess what ??? This worked!! Big Grin

Slight notation :  From the 10 times I move the "cart" over the slider rail it only missed once the input of a limit switch. So maybe 100K should be something smaller like 90K or so. The value of 47K is to low. But I can live with that, maybe in the future I order some 90K resistors.
Hello, after some problems with the stepper drivers my miniengine2 is working. Unfortunately the display i have (original ITEAD) had some vertical white lines so i contacted ITEAD for help/refund. In the meantime i ordered a new one just in case.
So today it arrived and i just checked it, this is the result...

Torque your video seems set to private.
(11-20-2015, 08:48 AM)Kynyc1 Wrote: Torque your video seems set to private.

I noticed, should be watchable now 
...Looks like they changed the hardware again #facepalm
I guess I need to speed up the development of a new version Wink
(11-24-2015, 02:20 PM)Airic Lenz Wrote: ...Looks like they changed the hardware again #facepalm
I guess I need to speed up the development of a new version Wink

Or re-write the code for the display, it's just inverted i guess. Contacted ITEAD and the're shipping a new one if that one has the same issue it's definitely something with the display driver.(again)


Recieved a new unit from itead works perfect, so the problem is in the LCD
Airic hello!
First I want to wish you and all the other's members on this forum a lot of health, luck and success in 2016.

I just have few questions.
If I start the preview and my start point was not correctly set, and the cart hit the limit switch - there is no response to the switch.
And why sometimes won't let me to run preview, some pop-up window shows,.. "motor-speed limit for at least one motor exceeded for this move"
my motor settings are:
motor: nema 14 / 5:1 gearbox / 0,8a
max speed: 4.5cm/s -any higher it oversteps   
calibration: 4160st/cm
ramp: 2,5s

And second thing,.. if I set the TOTAL DISTANCE somewhere in the middle of track and then move the cart with JOG function to it's actual limit position and hit SET START,
it overwrites the before set TOTAL DISTANCE. I don't know how this works for the others but is it possible to somehow fix this?

Planning to use the engine without limit switches as well. Shy


Samsung S7 cover casesam
It's possible to make it run 3 motors without the curves. We can use accelstepper library for the start and the end.

Also I would like to know if I can use proximity sensors instead of limit swithes?

Forum Jump:

Users browsing this thread: 5 Guest(s)